2

I tried to add "@Stéphane" in front of a comment but it got eaten by the system. Any idea if this is expected? I didn't see anything on metaSO but I probably didn't find the good search terms. "@St" worked, "@Sté" not, so I can only assume the accent is what the system chokes on.

| |
4

This is confusing but expected behavior. It is not related to the presence of an accented letter. If you try to notify the author of the post in a comment, the notification is silently removed when you post the comment. @Stéphane would have notified the question author, so it was silently stripped. @St is not a valid notification, because at least 3 characters from the name are needed, therefore it was left in place.

See How do comment @replies work?


Les règles sur les notifications dans les commentaires sont assez compliquées. Voici les principaux points à retenir (voir les règles en anglais pour plus de détails) :

  • On peut mettre une notification maximum par commentaire.
  • On peut notifier uniquement l'auteur d'un des commentaires précédents, quelqu'un qui a édité le message auquel est attaché le commentaire, ou (sous une question, le cas échéant) le modérateur qui a fermé la question.
  • Si on tente de notifier l'auteur du message sous lequel est le commentaire, cette notification est supprimée silencieusement au moment où le commentaire est soumis. L'auteur sera prévenu du commentaire de toute façon.
  • Une notification consiste en le signe @ suivi du nom affiché de l'utilisateur que l'on veut notifier (en omettant les espaces). Il faut inclure au moins les trois premières lettres.
| |
  • Thanks, I suspected something like this too at some point but dismissed it because I hadn't noticed it until recently (which made me also suspect the switch to public beta) and it didn't always happen. I completely overlooeked the fact that I was trying to message the post owner because I was in fact trying to answer a comment from him. Not to mention the accent is exactly at the 3-letters boundary required to notify someone... No wonder I was tricked into thinking the problem was there. Anyway, Thanks. – Joubarc Aug 25 '11 at 14:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .